# Honor system date format settings

**URL:** https://discourse.notenik.app/t/honor-system-date-format-settings/260
**Category:** Feature Requests
**Tags:** confirmed
**Created:** [July 21, 2023, 4:00pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260 "2023-07-21T16:00:11Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![ErikMH](https://discourse.notenik.app/user_avatar/discourse.notenik.app/erikmh/32/66_2.png) [@ErikMH](https://discourse.notenik.app/u/ErikMH)
#### Post date: [July 21, 2023, 4:00pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/1 "2023-07-21T16:00:11Z")

</div>

> The user interface and documentation are written in (mostly American) English, and both are too extensive to be easily translated into other languages.

— Notenik “Product Vision” № 9: Presented in English

* * *

I do understand the challenge of ever making a fully i18n’d version of Notenik — it’s so very text-centric! However, there may be some areas in which it could be made a little friendlier to users in other parts of the world (no matter their preferred language), or even for Americans who happen to have unusual preferences.

My preferred date format, for example, is ISO 8601:

![](https://discourse.notenik.app/uploads/db0641/original/1X/8609b3ee8145defd9c569675c90c039210c55657.png)  
— [xkcd № 1179](https://xkcd.com/1179)

Notenik does support this format pretty well, which makes me happy! 😄

But I would be happier yet if it honored my “First day of week” setting. Ever since I saw my first German calendar as a teen, I have _vastly_ preferred the layout where the week_ **end** _ is placed at the _ **end of the week** _, instead of split in two with Sunday as the first day:

 ![Screenshot 2023-07-21 at 11.34.04](https://discourse.notenik.app/uploads/db0641/original/1X/3179c2cd554166c63af0eabab2daf0bb2cb0b1d3.png)

This is not an important enough issue that I’d want it to take you away from more vital work; however, if it seems fairly simple, there are those of us who would be grateful.

Thanks for considering it!

---

<div class="post-metadata">

### Author: ![wgrace](https://discourse.notenik.app/user_avatar/discourse.notenik.app/wgrace/32/53_2.png) [@wgrace](https://discourse.notenik.app/u/wgrace)
#### Post date: [July 22, 2023, 9:30am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/2 "2023-07-22T09:30:18Z")

</div>

I’m all for this as well. I’ve always found Sunday as the first day of the week somewhat archaic.

---

<div class="post-metadata">

### Author: ![ErikMH](https://discourse.notenik.app/user_avatar/discourse.notenik.app/erikmh/32/66_2.png) [@ErikMH](https://discourse.notenik.app/u/ErikMH)
#### Post date: [July 23, 2023, 1:53am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/3 "2023-07-23T01:53:29Z")

</div>

I may have spoken too soon about Notenik’s use of ISO 8601. I was so bedazzled by the mere existence of the _Standardize Dates to YMD_ option in the _Collection_ menu, that I never really did any actual testing.

If I create a new empty collection with a _Date_ field, and then use the _Today_ button to enter today’s date, Notenik uses `dd Mmm yyyy` format, even though my system setting is (and forever shall be!) `yyyy-mm-dd`.

The date is then presented in the collection list as `dd Mmm yyyy / Dd`. And in the display of the note, it’s `dd Mmm yyyy`.

If I choose the aforementioned _Standardize_ menu command, Notenik tells me that `1 Note was updated`. (Nicely done with the singular and plural forms, btw — if there were two, it says `2 Notes were updated`.)

However, nothing actually changes, even after reloading the collection.

And if I look at the underlying `.md` file, I see that the `Date:` line also contains the date in `dd Mmm yyyy` format.

Now, in the grand scheme of the universe there are many date formats that are considerably worse than `dd Mmm yyyy`. (RFC 4021, RFC 2822, RFC 822 §5.1, and RFC 2822 §3.3 (_all_ for email!), I’m looking at you!) But I really do want `yyyy-mm-dd`.

So, once again, I’m not sure whether this is a bug (_Standardize Dates to YMD_ doesn’t do what it says on the tin) or a typo (perhaps it should read _Standardize Dates to DMY_), or what.

So I’m putting this here as a feature request. Could there please be a way for me to have _all_ Notenik dates stored and processed and sorted and presented as `yyyy-mm-dd`?

---

<div class="post-metadata">

### Author: ![hbowie](https://discourse.notenik.app/user_avatar/discourse.notenik.app/hbowie/32/6_2.png) [@hbowie](https://discourse.notenik.app/u/hbowie)
#### Post date: [July 25, 2023, 8:46pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/4 "2023-07-25T20:46:33Z")

</div>

Check out the [latest beta](https://discourse.notenik.app/t/beta-version-12-5-4-available-for-testing-on-july-25th-2023/272), which should fix the problem of standardizing dates as they appear on disk.

I’m a little bit conflicted about changing the display, though. The current format I’m using, with day of month, short alpha name of month, year, then alpha day of week just seems so darned _readable_. And I’m a bit of the school that an opinionated design is better than an infinitely flexible design that throws all choices back into the laps of the users.

But certainly open to more discussion on the topic.

---

<div class="post-metadata">

### Author: ![hbowie](https://discourse.notenik.app/user_avatar/discourse.notenik.app/hbowie/32/6_2.png) [@hbowie](https://discourse.notenik.app/u/hbowie)
#### Post date: [July 26, 2023, 10:29pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/5 "2023-07-26T22:29:34Z")

</div>

@wgrace and @ErikMH: Check out the [12.5.5 beta](https://discourse.notenik.app/t/beta-version-12-5-5-available-for-testing-on-july-26th-2023/273) I just posted and let me know how this works for you! The Notenik date picker (Calendar window) should now respect your System Setting for first day of week.

---

<div class="post-metadata">

### Author: ![hbowie](https://discourse.notenik.app/user_avatar/discourse.notenik.app/hbowie/32/6_2.png) [@hbowie](https://discourse.notenik.app/u/hbowie)
#### Post date: [July 27, 2023, 8:23pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/6 "2023-07-27T20:23:31Z")

</div>

A question here for you, @ErikMH, and anyone else interested in dates.

I’m updating Notenik to respect the user’s Systems setting for first day of week.

In terms of greater flexibility in date formatting in displays (such as adherence to ISO 8601), I’m not sure what your intentions might be: adhere to some sort of system setting, or allow the user to modify a Notenik setting to change display formats for dates?

---

<div class="post-metadata">

### Author: ![wgrace](https://discourse.notenik.app/user_avatar/discourse.notenik.app/wgrace/32/53_2.png) [@wgrace](https://discourse.notenik.app/u/wgrace)
#### Post date: [July 28, 2023, 6:55am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/7 "2023-07-28T06:55:04Z")

</div>

Thanks @hbowie all works well so far.

While I am strongly of the opinion that recorded date (in the text file itself) should be `yyyy-mm-dd`, I’m not particularly bothered by the note display itself.

Well, just as long as it is never MDY in numeric-only form, e.g. 07/28/2023, without being able to be changed to something else.

---

<div class="post-metadata">

### Author: ![wgrace](https://discourse.notenik.app/user_avatar/discourse.notenik.app/wgrace/32/53_2.png) [@wgrace](https://discourse.notenik.app/u/wgrace)
#### Post date: [July 28, 2023, 6:58am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/8 "2023-07-28T06:58:15Z")

</div>

> … adhere to some sort of system setting, or allow the user to modify a Notenik setting to change display formats for dates?

I’d be happy with one or the other.

---

<div class="post-metadata">

### Author: ![hbowie](https://discourse.notenik.app/user_avatar/discourse.notenik.app/hbowie/32/6_2.png) [@hbowie](https://discourse.notenik.app/u/hbowie)
#### Post date: [August 5, 2023, 10:05pm UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/9 "2023-08-05T22:05:41Z")

</div>

BTW, @wgrace, is the variable first day of the week working out for you with the latest release?

Just looking for some confirmation that I scratched that itch.

---

<div class="post-metadata">

### Author: ![wgrace](https://discourse.notenik.app/user_avatar/discourse.notenik.app/wgrace/32/53_2.png) [@wgrace](https://discourse.notenik.app/u/wgrace)
#### Post date: [August 6, 2023, 2:31am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/10 "2023-08-06T02:31:12Z")

</div>

@hbowie certainly does, thanks. One of those things that, once the friction of the original annoyance is gone, fades into the background nicely.

---

<div class="post-metadata">

### Author: ![ErikMH](https://discourse.notenik.app/user_avatar/discourse.notenik.app/erikmh/32/66_2.png) [@ErikMH](https://discourse.notenik.app/u/ErikMH)
#### Post date: [August 27, 2023, 12:31am UTC](https://discourse.notenik.app/t/honor-system-date-format-settings/260/11 "2023-08-27T00:31:14Z")

</div>

Either would be just fine. I suppose my _hope_ would be that it would default to my system setting, but that I could override it. But honestly, I personally want the same date format everywhere, the slightly-modified ISO-8601 format that I have had as my system default for as long as that was a possibility:

yyyy-mm-dd hh:mm[:ss]

I say “slightly-modified,” recognizing that strict ISO-8601 wants a `T` between the date and the time, that the seconds aren’t really optional, and that a time-zone offset is supposed to be included. I recognize that this introduces the ambiguity of whether it represents UTC (GMT) or my own local time, but I’ve built my own conventions such that _if_ it matters, I’ll know for sure which I’ve used.
