Notenik 13.1: <body> missing in display

After updating from v12, a Collection I’ve been working with for since the start no longer shows the in Display mode. I don’t see anything amiss in either the Settings or the template, neither of which I changed.

Where would I look to restore it?

No longer shows the body in Display mode?

Can you send me the template and the settings, and perhaps one of the Notes that is having trouble?

Can you check that you are running the latest version (13.1.0) from your Applications folder, and that you don’t have any old beta versions still sitting around somewhere? I seem to remember people having similar problems when they had too many betas in their Downloads folder.

Just looking at this now, thanks.

One Collection functions normally. In its settings, the Body option is unchecked but in the non-displaying Collection it is checked.

And this is the non-displaying Collection’s settings:

Yes, 13.1.0:

No other Notenik installed. Tested on Monterey and Ventura.

Attached is the non-displaying Collection’s template. And one item. (1.8 KB)

The body tag for the HTML in the problem Collection is:


whereas in the working Collection it’s:


So it sounds like you are using a display.html file? If so, could you send that to me as well?

My other thought would be to turn off the Collection setting that says attempt to sync the edit and display scrolling. I can imagine this might be causing a problem, especially if you are trying to use it with a display.html merge template.

Here’s the display.html file. (1.5 KB)

The Collection originally had sync off (because it didn’t exist). I turned it on to see if it would help. It doesn’t seem to matter whether it’s on or not.

When I was testing sync on a beta copy a long time ago, both sync and the body display were working, though. Obviously.

Well, now I can see the problem. Let me investigate further.

Bravo – and thanks for investigating on a Sunday afternoon! No urgency here.

Check out the new beta. I believe this should fix the problem.

Yes, I can see the body text in Display mode now. Thanks!

Thanks for reporting the problem, and supplying so much helpful information!

1 Like